Back to overview
Downtime
TSA services temporarily unavailable
Jun 07 at 10:06pm BST
Resolved
Jun 08 at 06:17pm BST
All certificates have been renewed and all sites are operating as expected.
Affected services
Created
Jun 07 at 10:06pm BST
SSL certificates used on the verification and management websites have expired, meaning all connections are blocked, presenting a 526 error.
We're working to get these certificates renewed and services restored.
Affected services